Upcoming changes to Macintosh minimum requirements

Greetings Fruit-Computer-Using Spacefriends,

This summer we’re going to be releasing some foundation technology updates to the Macintosh client for EVE Online. As can happen with such things, we need to update our minimum supported OS version to one that supports the new hotness. Specifically we’ll start requiring OS X 10.7 – Lion. If you’re one of those folks using a Leopard version, Snow variety or otherwise, you need to upgrade to at least Lion in order to continue flying the unfriendly skies.

We haven’t got a date pinned down for this exactly but it should land somewhere in May or June. I’m hopeful that giving a few months warning allows everyone to make time for the update so this is a smooth transition for all involved.