Changes To Macintosh Minimum Requirements With Kronos | EVE Online

Changes To Macintosh Minimum Requirements With Kronos

As detailed in this news item from February 2014, we are now ready to raise the minimum requirements for the Macintosh client to play EVE Online.

From tomorrow, with the deployment of the Kronos release, Macintosh users will require a minimum of OSX 10.7 - Lion to be able to play EVE Online. If you are still using a Leopard version, Snow variety or otherwise, you need to upgrade to at least Lion in order to continue flying in New Eden.

The Kronos release will be deployed  tomorrow, June 3rd 2014 in an extended downtime. For further information please see this news item.