Changes to CPU requirements with Incursion 1.1.0

TL;DR: CPUs that don't support the SSE2 instruction set will not be able to run EVE Online after the Incursion 1.1.0 deployment on Tuesday, January 18, 2011. This will cause players still using Intel Pentium 3 or older and AMD Athlon XP or older CPUs to not be able to run the EVE Online client. Athlon 64 CPUs are not affected.

During the testing of Incursion 1.1.0 we received reports of a seemingly random issue that caused the client to crash on startup. While some of our Singularity testers reported the issue, we weren't able to replicate it. The error log that was generated didn't prove to be helpful, and due to the extremely few reports we received on it, we couldn't take the investigation further.

In an epiphany moment, a diligent tester figured out that some of the third party binaries we use to run EVE Online had been updated recently. Looking further into the issue, we found that a feature had been turned on that used the SSE2 instruction set and the unexpected fallout was that non-SSE2 capable CPUs became incompatible.

We've looked at hardware trend reports and the general status of the market and this obsolete generation of CPUs in desktop computers and gaming rigs is nearly extinct. We estimate that around 0.3% of the playerbase will be affected. We have, therefore, decided to not let this block the deployment of Incursion 1.1.0. An info message that pops up when you start the client on a non-SSE2 capable machine has been added for clarification. We urge everyone who encounters this specific error to submit a petition to our customer support department. We will have updates on the next steps we take with this issue immediately after the weekend but we wanted to get a blog up ASAP to inform everyone about the issue.

Cheers,

CCP Zulu