Updates To Minimum OS Requirements For Mac Users | EVE Online

 
Back to news

Updates To Minimum OS Requirements For Mac Users

2018-09-24 - By CCP Falcon

As part of ongoing work to keep New Eden up to date, the minimum specifications to play EVE Online are always under review.

This ensures that any changes we make to the EVE Client will perform as expected and that we have a solid understanding of how a release will affect the performance of your hardware.

We'll be making changes tomorrow that require an update to the minimum system requirements for Mac users. This will mean that our minimum system requirements will change to reflect the following:

  • Formal support of 10.14, 10.13 and 10.12.
  • 10.11 will work, but will not be supported.
  • 10.10 and older will stop working.

This change will come into effect at downtime tomorrow, 2018/09/25.

If you'd like to discuss it, you can do so in this forum thread.